I suggest you ...

BUG in the installation process of SCOM 1801 Web Console (WORKAROUND)

Hi together,
again there is a bug in the Web Console, this time in SCOM 1801.

I installed SCOM 1801 Web Console using "Enable SSL" option. But if I browse on Internet Explorer, or Firefox, etc. https://<WEB CONSOLE>/OperationsManager gives the following error:
"The remote server returned an error: (404) Not found".

I could broswe the following pages without any problem:
https://<WEB CONSOLE>/Dashboard
https://<WEB CONSOLE>/AppAdvisor
https://<WEB CONSOLE>/AppDiagnostics

I figured out the issue
--------------------------
If I install SCOM Web Console without "Enable SSL", then the access to Web Console works.

SCOM Web COnsole installation process with "Enable SSL" does not set in IIS "SSL required" option, and does not set any Web Console registry parameter value automatically. I could reproduce this behaviour many times.

WORKAROUND
--------------------------
1) Set "SSL Reuired" manuals in IIS:
After the installaion of Web Console with "Enable SSL" set following:
"Default Web Site > SSL Settings", and enable "SSL required"

2) Set Registry parameter values manually:
"HKLM\SOFTWARE\Microsoft\System Center Operations Manager\Setup\Web Console"
BINDING_CONFIGURATION: DefaultHttpsBinding
HTTP_GET_ENABLED: false

That is definetly a bug in the installation process of SCOM 1801 Web Console. This instasllion BUG must be fixed by SCOM developer team.

Discussion link about this problem:
https://social.technet.microsoft.com/Forums/en-US/aa088cb8-f3c0-4486-ac9a-26a78a7277fe/scom-1801-web-console-installation-issue?forum=operationsmanagerdeployment

Best Regards
Birdal

1 vote
Vote
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    Birdal shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

    2 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      Signed in as (Sign out)
      Submitting...
      • Craig Wilson commented  ·   ·  Flag as inappropriate

        I got a similar issue with the web console over SSL
        I could access it fine over HTTP:// but got "Underlying connection was closed" error when trying over HTTPS://
        After much investigation I managed to fix it by changing my IIS Binding for HTTPS
        FROM: <serverip>:443
        TO *:443

        Not sure as to the reason why as this was fine in SCOM 2016...

      • Birdal commented  ·   ·  Flag as inappropriate

        Hi all,
        Microsoft customer responsible controverts this bug.
        I can reproduce the isntallation issue with "Enable SSL" many times.
        How about with your experiences with this option? Does this installation set all necessary parameters correctly (registry, IIS, etc.)?
        I am sure not.
        Best Regards
        Birdal

      Feedback and Knowledge Base