I suggest you ...

Keep NOAPM=1 as default setting for all MMA versions

The APM component (regardless of APM being enabled) frequently breaks .NET applications. Re-installing agent with NOAPM=1 means we cannot leverage the SCOM console to deploy agents. Request

144 votes
Vote
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    Subramani Ananthapadmanabhan shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

    4 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      Signed in as (Sign out)
      Submitting...
      • Thorsten S commented  ·   ·  Flag as inappropriate

        @John West,
        we are using this command to remove the APM component from already installed agents:
        msiexec /fvomus \\<server>\share$\MOMAgent.msi NOAPM=1
        You can run it from the SCOM mangement view using "Execute any PowerShell". Important bit is, that the UNC path doesn't contain any spaces.

      • Subramani Ananthapadmanabhan commented  ·   ·  Flag as inappropriate

        If one reconfigures the agent with NOAPM=1; then "Pending Management" updates ( in the event of applying a UR) fails from the console. The console expects APM component to be installed; so this would require a fix in the console side as well.

      • John West commented  ·   ·  Flag as inappropriate

        As an alternative, I would love to see a method to change this configuration without a full installation of the client.

      Feedback and Knowledge Base